DNS Service Disruption
Incident Report for Server Status | Nexcess
Monitoring
The DNS service is currently stable, and we're monitoring it.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, using the client portal ticket, or live chat.
Posted Oct 21, 2024 - 14:16 EDT
Investigating
We are investigating an issue where a portion of DNS Services are degraded. This impacts other platform features as well. We will post further updates as we have more information.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, using the client portal ticket, or live chat.
Posted Oct 17, 2024 - 06:46 EDT
This incident affects: Nexcess Global DNS.