GitHub Peformance Impact

Incident Report for Nexcess Server Status

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 16:16 EDT

Investigating

This issue is currently affecting the ability to create new Magento, Wordpress, and WooCommerce websites and some dedicated cloud plans through the Nexcess customer portal. Nexcess Engineering and Development teams are currently reviewing the service impact and evaluating options to return service as quickly as possible. We will provide further updates as soon as they are available.

We appreciate your patience as our team works to resolve this issue. If you have further questions or concerns, please contact us at support@nexcess.net or via Live Chat.
Posted Aug 17, 2026 - 12:27 EDT

Identified

GitHub is reporting degraded performance via their status page this morning:
https://www.githubstatus.com/

Per the page, this problem may be affecting Pull Requests, Issues, Copilot, Actions, Webhooks, and API requests, among other services. Customers should follow the GitHub status page for the latest information.
Posted Aug 17, 2026 - 11:35 EDT
This incident affected: Customer Portal.