Nexcess Customer Portal Degraded
Incident Report for Server Status | Nexcess
Resolved
This issue is now resolved.
Posted May 10, 2023 - 08:59 EDT
Monitoring
Our teams have implemented a fix and the portal is now functioning as expected. We are currently monitoring to ensure no further issues.
Posted May 09, 2023 - 11:54 EDT
Investigating
We have identified an issue impacting the stability of the Nexcess customer portal/dashboard. Our engineers are currently looking into this. As we have more information we will update this status post.

Our teams are here to help you. Please do not hesitate to contact us via an email to support@nexcess.net or call us at 866-639-2377, 1-313-279-0722 (international).
Posted May 09, 2023 - 10:34 EDT