Service Disruption – Nexcess.net Website

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 15:12 EDT

Monitoring

The issue affecting access to Nexcess.net has been resolved, and the site is now accessible. Our engineering team has implemented a fix and is closely monitoring to ensure stability.

If you have any questions or concerns, please don’t hesitate to reach out via live chat or by opening a support case.
Posted Sep 09, 2025 - 13:41 EDT

Investigating

We are experiencing an issue affecting access to our official website, Nexcess.net. Our engineering team is actively investigating and working to restore full availability quickly.

We will provide an update as soon as more information becomes available.

We appreciate your patience and understanding during this time. If you have any questions or concerns, please don’t hesitate to reach out via live chat or by opening a support case.
Posted Sep 09, 2025 - 13:15 EDT
This incident affected: Support Services (Help Center).