Salesforce Issues
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 01:35 EDT
Investigating
We have been informed and that our ticketing system is having some performance issues. We are currently investigating this issue and will provide more details when they are gathered.
Posted Jun 15, 2021 - 01:00 EDT
This incident affected: Support Services (Tickets, Phones, Chats).