Broad Cloudflare service outages

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:08 EDT

Monitoring

Cloudflare services are recovering, and in turn we are seeing our services return to normal as well. We will continue to monitor the situation.
Posted Jun 12, 2025 - 16:36 EDT

Investigating

Cloudflare, Google Cloud, and subsequently other major internet services are experiencing outages at the moment. During this time our portal login and purchasing capabilities may be degraded. We are investigating the issue and will provide updates as best we can.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net.
Posted Jun 12, 2025 - 14:57 EDT
This incident affected: Platform Operations (DNS) and Nexcess Global DNS.