DDoS Attack on cloudhost-3835690.uk-south-2.nxcli.net

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 10:00 EDT

Investigating

Our teams have identified a distributed denial of service attack (DDOS) on cloudhost-3835690.uk-south-2.nxcli.net. Our network engineers are working on mitigation at this time. We will provide another update as soon as more information becomes available.

We appreciate your patience as our networking teams work to mitigate the DDoS. If you have further questions or concerns, please contact us at support@nexcess.net or via Live chat
Posted Mar 15, 2025 - 08:57 EDT
This incident affected: Nexcess Cloud (uk-south-2).