US-Midwest Cloud Host Server Outage (2 Servers Down)

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 04:25 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2026 - 02:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 02:49 EDT

Investigating

We are currently experiencing an issue affecting two cloud host servers in the US-Midwest region. Our internal teams are actively investigating and working to restore services. We will continue to provide updates here as more information becomes available.

We appreciate your patience. If you have any questions or concerns, please contact us at support@nexcess.net
or via Live Chat.
Posted Apr 10, 2026 - 02:08 EDT
This incident affected: Nexcess Cloud (us-midwest-1).