Nexcess Client Portal Login Issues

Incident Report for Server Status | Nexcess

Resolved

The Nexcess Client Portal login issue has been resolved. Services are now fully operational, and no further impact has been observed.
Posted Nov 12, 2025 - 07:59 EST

Monitoring

A fix has been implemented, which has resolved the issues with the portal login. We are currently monitoring the results to ensure stability.
Posted Nov 11, 2025 - 16:55 EST

Investigating

We are currently investigating issues affecting the Nexcess Client Portal login. Our engineering team is actively working to identify the cause and restore full availability as quickly as possible.

We will provide updates as soon as more information becomes available.

We appreciate your patience and understanding during this time. If you have any questions or need assistance, please reach out via live chat or by opening a support case.
Posted Nov 11, 2025 - 16:28 EST
This incident affected: Customer Portal.