Multiple cloud hosts in the US-Midwest-1 region are currently experiencing an outage.

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Mar 22, 2026 - 00:06 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 21, 2026 - 01:50 EDT

Monitoring

We have mitigated the impact of the issue. Our network engineers have applied a fix, and all servers are now operating normally. We will continue to monitor the situation to ensure ongoing stability.

We understand the disruption this may have caused and appreciate your patience as our teams worked to resolve the issue. For any additional questions or concerns, please contact us at support@nexcess.net or via Live Chat.
Posted Mar 21, 2026 - 01:49 EDT

Investigating

Our teams have identified multiple Cloudhost outages in the Midwest-1 region. Our network engineers are working on mitigation at this time. We will provide another update as soon as more information becomes available.

We appreciate your patience as our networking teams work to mitigate the DDoS. If you have further questions or concerns, please contact us at support@nexcess.net or via Live chat.
Posted Mar 21, 2026 - 00:45 EDT
This incident affected: Nexcess Cloud (us-midwest-1).