Nexcess Outage
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 13:10 EST
Monitoring
We have implemented a fix to issue causing our websites and hosting services to experience interruptions. We will update this status post as more information is available.

We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net
Posted Dec 11, 2024 - 11:42 EST