DDoS Attack on cloudhost-3399520.us-west-1.nxcli.net

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Apr 28, 2025 - 13:56 EDT

Monitoring

The Network Engineering team has implemented a fix to restore service, and affected systems are now online and stable. We are actively monitoring the network environment to ensure stability.

We appreciate your patience during this time! If you have any questions or concerns. Please get in touch with us via live chat or case.
Posted Apr 25, 2025 - 20:28 EDT

Identified

Our teams have identified a distributed denial of service attack (DDOS) on cloudhost-3399520.us-west-1.nxcli.net. Our network engineers are working on mitigation at this time. We will provide another update as soon as more information becomes available.

We appreciate your patience as our networking teams work to mitigate the DDoS. If you have further questions or concerns, please contact us at support@nexcess.net or via Live chat.
Posted Apr 25, 2025 - 20:06 EDT