Customer Portal Degraded
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted May 25, 2022 - 17:35 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2022 - 15:05 EDT
Investigating
We are currently investigating reports of issues with our control panel. We will update this status post as we have more information.

If you have any questions, please do not hesitate to contact a member of our support team by email at support@nexcess.enet, via live-chat or ticket or by phone, toll-free at 866-639-2377 or internationally at +1.517.322.0434.
Posted May 25, 2022 - 13:27 EDT