Potential Increase in Support Response Times
Incident Report for Server Status | Nexcess
Resolved
We have identified an issue and implemented the fix. Issue has now been resolved.
Posted Jun 11, 2022 - 05:43 EDT
Investigating
We are currently investigating errors within our chat and ticketing system due to recent maintenance. At the moment, chat and ticketing systems are fully operational, however, there is a possibility of increased response time from our Support team. Customers can contact us via phone calls as well, which at the moment are not affected.

If you have any questions, please contact a member of our support team via ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Jun 11, 2022 - 04:56 EDT
This incident affected: Support Services (Tickets, Chats).