Our 3rd party vendor has confirmed the backup issue is resolved. At this time we do not have information on the exact cause.
If you have any further questions or concerns, please feel free to reach out to us by live chat in your customer portal (https://my.nexcess.net/), by emailing support@nexcess.net or by calling us at 866-639-2377, 1-313-279-0722 (international)
Posted Mar 03, 2025 - 18:50 EST
Update
We are in communication with our 3rd party vendor, and they are working diligently on the issue. During this incident our scheduled backups are not running as expected. Existing backups are intact, but we're unable to access/utilize them. We will provide more information as it becomes available.
If you have any further questions or concerns, please feel free to reach out to us by live chat in your customer portal (https://my.nexcess.net/), by emailing support@nexcess.net.
Posted Mar 03, 2025 - 17:36 EST
Investigating
We experiencing problems with our third party vendor that provides backups for the Nexcess portal.
Our operations team is looking into a problem right now.
We apologize for the inconvenience. This post will be updated as soon as more information is available.
If you have any further questions or concerns, please feel free to reach out to us by live chat in your customer portal (https://my.nexcess.net/), by emailing support@nexcess.net.