DNS Service Disruption
Incident Report for Server Status | Nexcess
Resolved
The DNS service is stable and this incident has been resolved.
Posted Oct 16, 2024 - 08:07 EDT
Monitoring
The DNS service is stable at this time and we're monitoring it.
Posted Oct 15, 2024 - 07:02 EDT
Investigating
We are currently investigating an issue where timeouts are observed on Nexcess Nameservers. We will post further updates as we have more information.

If you have any questions feel free to reach out to our support at support@nexcess.net or via Live Chat.
Posted Oct 15, 2024 - 06:48 EDT
This incident affected: Nexcess Global DNS.