Email Services Degraded
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Feb 20, 2023 - 05:30 EST
Investigating
Users of our Premium Business Email services are reporting issues with logging in at this time. Our teams are currently working to identify the root cause of this issue. As we have additional info we will provide updates here.
You may also check out the rackspace statuspage for more information. https://status.apps.rackspace.com/index/viewincidents?group=100&start=1676696400

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 18, 2023 - 14:06 EST
This incident affected: Platform Operations (Email).