Interworx Licensing Issue

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 05:29 EDT

Monitoring

Our Engineering Team has implemented the fix, and we have confirmed that the Interworx portal is working fine.

We are actively monitoring to ensure stability.

We appreciate your patience during this time! If you have any questions or concerns.
Please get in touch with us via live chat or case.
Posted Oct 03, 2025 - 01:24 EDT

Investigating

There is currently an issue with Interworx's Licensing on a subset of clusters of dedicated servers.

You may experience issues with accessing the Interworx portal, and our team is working on it.
We will update this status when more information is available on the situation.

Live Chat via the Customer Portal: https://my.nexcess.net/
Email: support@nexcess.net

We sincerely appreciate your patience and understanding as we work to enhance our services.
Posted Oct 03, 2025 - 00:15 EDT
This incident affected: Platform Operations (InterWorx Control Panel).