Service interruption on subset of Cloudhosts at US-Midwest-2 Region

Incident Report for Nexcess Server Status

Resolved

This incident has been resolved.
Posted Sep 12, 2026 - 09:56 EDT

Monitoring

Our engineers have successfully recovered the impacted cloudhosts.

We are continuing to monitor the environment to ensure stability and will keep this space updated as needed
Posted Sep 12, 2026 - 04:35 EDT

Investigating

We are currently investigating a performance issue affecting a subset of our cloudhosts, cloudhost-4892688.us-midwest-2.nxcli.net and cloudhost-4892180.us-midwest-2.nxcli.net, in the US-Midwest-2 region. Customers may experience slowness or degraded performance, and there is a potential for service interruption while the issue is being investigated.

Our systems engineers have been engaged and are working to identify the cause and restore normal performance as quickly as possible.

We appreciate your patience. If you have any questions or concerns, please contact us via live chat or case.
Posted Sep 12, 2026 - 04:12 EDT
This incident affected: Nexcess Cloud (us-midwest-2).