Let's Encrypt SSL Certificate Renewal Failures
Incident Report for Server Status | Nexcess
Resolved
This issue is resolved. Let's Encrypt has confirmed that SSL renewals are now functioning as expected.
Posted Dec 02, 2021 - 16:35 EST
Investigating
We have been made aware of a Let's Encrypt outage that is affecting renewals of their SSL certificates. We will update this post as more information becomes available.

If you have any questions, please do not hesitate to contact a member of our support team via Support Ticket, E-Mail at support@nexcess.net or by toll-free phone at 866-639-2377 or international at +1.517.322.0434.
Posted Dec 02, 2021 - 16:09 EST