Acronis Backup Functionality Degraded
Incident Report for Server Status | Nexcess
Resolved
This issue is now resolved. Acronis backups are functioning as expected at this time.
Posted Dec 21, 2021 - 11:58 EST
Investigating
Our teams are currently investigating issues with Acronis backup functionality. We will update this status post as more information becomes available.

If you have any questions, please do not hesitate to contact a member of our support team via Support Ticket, E-Mail at support@nexcess.net or by toll-free phone at 866-639-2377 or international at +1.517.322.0434.
Posted Dec 20, 2021 - 12:16 EST