Let's Encrypt Self Service
Incident Report for Server Status | Nexcess
Resolved
This issue is now resolved.
Posted Jan 28, 2022 - 16:06 EST
Identified
We are aware of some issues with the ability to toggle Let's Encrypt in the customer portal. Our team has identified the issue and is working on a resolution at this time.
Posted Jan 28, 2022 - 13:05 EST
This incident affected: Customer Portal.