Service Interruption on US-Midwest 2 region

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 03:25 EDT

Monitoring

The Network Engineering team has detected and implemented a fix to restore service interruption in US-Midwest 2 region , and affected systems are now online and stable. We are actively monitoring the network environment to ensure stability.

We appreciate your patience during this time! If you have any questions or concerns. Please get in touch with us via live chat or case.
Posted Sep 19, 2025 - 04:47 EDT
This incident affected: Nexcess Cloud (us-midwest-2).