Website and Service Provisioning Disruption
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Feb 25, 2023 - 19:14 EST
Monitoring
Our team has deployed the fix though results are still being monitored at this time. Thank you for your continued patience.
Posted Feb 24, 2023 - 15:55 EST
Identified
Our Developers have identified an issue impairing the provisioning of new sites and services through our customer portal. A change to correct the problem is in review at this time.

We apologize for any inconvenience or disruption in workflow this may have created. Our team can be reached via email at support@nexcess.net, through the customer portal (https://my.nexcess.net) via ticket or chat, or by calling toll-free at 866-639-2377 or +1-517-322-0434 (international).
Posted Feb 24, 2023 - 15:18 EST
This incident affected: Customer Portal.