Cloudflare Network Degradation

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 23:34 EST

Identified

Cloudflare is currently experiencing network degradation in the Chicago area. This is impacting some Liquid Web services, including:

Account Signups: Potential failures during registration.

Provisioning: Delays in getting new orders online.

Portal Tools: Intermittent errors when adjusting Cloudflare features.

We apologize for the inconvenience. We are monitoring the situation closely and will provide updates as they become available.

Cloudflare Status: https://www.cloudflarestatus.com/incidents/3xb30dhqfkw7
Posted Jan 27, 2026 - 16:32 EST

Update

Cloudflare is currently experiencing network degradation in the Chicago area. This is impacting some Nexcess services, including:

Account Signups: Potential failures during registration.

Provisioning: Delays in getting new orders online.

Portal Tools: Intermittent errors when adjusting Cloudflare features.

We apologize for the inconvenience. We are monitoring the situation closely and will provide updates as they become available.

Cloudflare Status: https://www.cloudflarestatus.com/incidents/3xb30dhqfkw7
Posted Jan 27, 2026 - 15:59 EST

Investigating

We are currently tracking a network degradation issue affecting the Chicago, IL area. Our upstream provider, Cloudflare, is working to resolve the matter.

We are monitoring the situation closely and will provide updates as they become available.

Cloudflare Status: https://www.cloudflarestatus.com/incidents/3xb30dhqfkw7
No components were marked as affected by this incident.
Posted Jan 27, 2026 - 15:43 EST
This incident affected: Customer Portal.