Client portal down
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 08:45 EST
Monitoring
Our team has implemented a fix, and everything is currently operational. We are actively monitoring the situation.
Posted Dec 04, 2024 - 01:04 EST
Investigating
We are currently investigating an emergent issue that is impacting access to the client portal. Our support will be degraded during this incident as well.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net
Posted Dec 04, 2024 - 00:48 EST
This incident affected: Support Services (Tickets, Phones, Chats) and Platform Operations (InterWorx Control Panel).