Minor Outage on Subset of Cloudhosts on UK-South-2 Data Center

Incident Report for Nexcess Server Status

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 19:51 EDT

Identified

Following a scheduled maintenance on our UK-South infrastructure a hardware issue was identified and is impacting a subset of the maintained hosts. We have engaged with engineers onsite and are working to correct the issue. If you have any questions please reach out to our support team.

Live Chat via the Customer Portal: https://sites-portal.nexcess.com

Email: support@nexcess.net

We appreciate your understanding and patience as we work to enhance our service.

System Maintenance Reference: [CC-13363]
Posted Apr 15, 2026 - 18:58 EDT
This incident affected: Nexcess Cloud (uk-south-2).