Nexcess Client portal Down

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 05:40 EST

Investigating

We are currently investigating an emergent issue that is impacting access to the client portal. Our support will be degraded during this incident as well.
We apologize for the inconvenience. This post will be updated as soon as more information is available.

If you have any further questions or concerns, please feel free to reach out to us by live chat in your customer portal (https://my.nexcess.net/), by emailing support@nexcess.net.
Posted Feb 05, 2025 - 04:58 EST
This incident affected: Customer Portal.