Phone Service Degraded
Incident Report for Server Status | Nexcess
Resolved
This issue is now resolved. All contact phone numbers are functioning as expected at this time.
Posted Aug 22, 2023 - 14:07 EDT
Identified
We are currently investigating an issue reaching our teams via the phone number 1-866-639-2377. The number 1-313-279-0722 is still functioning as expected. We will update this status post as more information becomes available.

We appreciate your patience as our teams work to resolve this issue. If you have any further questions or concerns, please feel free to reach out to us by live chat in your customer portal (https://my.nexcess.net/), by emailing support@nexcess.net or by calling us at 1-313-279-0722 (international)
Posted Aug 22, 2023 - 10:44 EDT