Cart Degraded
Incident Report for Server Status | Nexcess
Resolved
Our teams have implemented a fix for this issue. Our cart is functioning as expected at this time.

Our teams are here to help you. Please do not hesitate to contact us by emailing support@nexcess.net, opening a ticket or chat in your customer portal (https://my.nexcess.net) , or by calling toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Feb 24, 2023 - 12:15 EST
Investigating
Our teams are investigating an intermittent issue completing purchases through our cart. We will update this status page as more information becomes available.

Our teams are here to help you. Please do not hesitate to contact us by emailing support@nexcess.net, opening a ticket or chat in your customer portal (https://my.nexcess.net) , or by calling toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Feb 24, 2023 - 11:08 EST