The issue affecting a subset of servers in our US-Midwest-2 Data Center has been resolved. Our Engineering team has confirmed that services are operating normally.
If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or via chat.
Posted Mar 15, 2026 - 11:13 EDT
Update
Our Engineering team has identified the cause of the service interruption affecting a subset of servers in our US-Midwest-2 Data Center. The team is actively working to implement a resolution and restore full service as quickly as possible. We will continue to provide updates as more information becomes available.
If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or via chat.
Posted Mar 15, 2026 - 09:31 EDT
Investigating
We are currently investigating a service interruption affecting servers in our US-Midwest-2 Data Center. Our dedicated Engineering teams are engaged and are working to restore service as quickly as possible. We will provide further updates as they become available.