The issue affecting multiple cloud hosts in the US-Midwest-2 region has been resolved. All affected services have been restored to normal operation.
Our engineering team will continue to monitor the environment to ensure stability.
If you have any questions or concerns, please don't hesitate to contact us via Live Chat or by opening a case.
Posted Feb 25, 2026 - 18:07 EST
Update
We are continuing to investigate this issue.
Posted Feb 25, 2026 - 17:52 EST
Investigating
We are currently investigating an issue affecting multiple cloud hosts in our US-Midwest-2 region.
Our engineering team is actively working to identify the root cause and restore full functionality. We will provide updates as more information becomes available.
If you have any questions or concerns, please don't hesitate to contact us via Live Chat or by opening a case.
Posted Feb 25, 2026 - 17:47 EST
This incident affected: Nexcess Cloud (us-midwest-2).