Cloudflare Service Issues

Incident Report for Server Status | Nexcess

Resolved

Cloudflare has reverted the change to their Web Application Firewall that caused the brief network disruption earlier today. Since the rollback, we have not observed any further issues.

For more details about the incident, please refer to Cloudflare’s official post:
https://blog.cloudflare.com/5-december-2025-outage/

If you have any questions or concerns, please don't hesitate to contact us via Live Chat or by opening a case.
Posted Dec 05, 2025 - 11:41 EST

Update

A change made to the way Cloudflare’s Web Application Firewall parses requests caused Cloudflare’s network to be unavailable for several minutes this morning (ET hours). We are continuing to see stability, and we will keep this space updated as we receive further information from the Cloudflare team.
Posted Dec 05, 2025 - 04:58 EST

Monitoring

Cloudflare team has implemented a fix and resolved the issue. We are monitoring the results.
Posted Dec 05, 2025 - 04:28 EST

Investigating

Cloudflare is currently investigating issues affecting the Cloudflare Dashboard and related APIs.

Customers using the Dashboard or Cloudflare APIs may experience failed requests or see error messages.

We are monitoring the progress being made by the Cloudflare team and will keep this space updated.
Posted Dec 05, 2025 - 04:22 EST