Degraded system storage performance

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 16:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2025 - 02:51 EDT

Identified

Our system engineers are working on upgrades to our backend storage system, and this has caused unintentional performance degradation. Access to our Cloud Object Storage and the use of Acronis backups may see intermittent timeouts or connection failures during this time. We apologize for the inconvenience, but are working diligently on stabilizing the system.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net.
Posted Jun 12, 2025 - 19:01 EDT
This incident affected: Platform Operations (Platform Updates / Other).