Storebuilder Degraded
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Feb 27, 2023 - 12:37 EST
Investigating
Our teams are aware of and working to resolve an issue with Storebuilder. Provisioning is not fully completing. We will update this status post as more information becomes available.

Our teams are here to help you. Please do not hesitate to contact us by emailing support@nexcess.net, opening a ticket or chat in your customer portal (https://my.nexcess.net) , or by calling toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Feb 27, 2023 - 12:02 EST