Password Credentials for Clients with VIP Plans

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved
Posted Dec 09, 2023 - 15:39 EST

Investigating

We are aware of an issue causing our clients with VIP Plans to have expired login credentials. We are currently working to field all incoming requests, however are experiencing high call and live chat volume at this time. If you are impacted and needing a reset for your login credentials for you VIP plan please open a ticket and we will address your issue as soon as possible.
Posted Dec 09, 2023 - 13:54 EST
This incident affected: Support Services (Phones, Chats).