DDoS Attack on Cloudhost-2095262.us-west-1.nxcli.net

Incident Report for Nexcess Server Status

Resolved

This incident has been resolved.
Posted May 04, 2026 - 23:28 EDT

Identified

Our teams have identified a distributed denial of service attack (DDOS) on Cloudhost-2095262.us-west-1.nxcli.net. Our network engineers are already enabled for mitigation. We will provide another update as soon as more information becomes available.

We appreciate your patience as our networking teams work to mitigate the DDoS. If you have further questions or concerns, please contact us at support@nexcess.net or via Live chat.
Posted May 04, 2026 - 20:18 EDT
This incident affected: Nexcess Cloud (us-west-1).