Network Disruption Impacting Multiple Hosts - US-Midwest-1

Incident Report for Server Status | Nexcess

Resolved

Our network team has resolved the issue, and all services are now functioning as expected. We are continuing to monitor the situation to ensure ongoing stability.
Posted May 19, 2025 - 05:20 EDT

Investigating

Our team is currently investigating a network issue affecting several hosts in the us-midwest-1 region including the customer portal. We will continue to update the status page as more information becomes available.
Posted May 19, 2025 - 02:34 EDT
This incident affected: Nexcess Cloud (us-midwest-1) and Customer Portal.