Service Interruption on Cloudhost | 76771

Incident Report for Nexcess Server Status

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 12:29 EDT

Monitoring

Our Engineering team has resolved the issue, and the host is now back online.

We are continuing to monitor the environment to ensure stability and will keep this space updated as needed.
Posted Jul 10, 2026 - 05:34 EDT

Investigating

We have encountered an issue with a CloudHost, and our engineers have identified the cause. The team is actively working towards a resolution.

We understand the impact this may have and will continue to provide updates here as progress is made. In the meantime, if you have any questions, please do not hesitate to contact our Support team via chat or email.
Posted Jul 10, 2026 - 05:15 EDT
This incident affected: Nexcess Cloud (us-midwest-1).