Portal Performance Degraded

Incident Report for Server Status | Nexcess

Resolved

Our teams have released an update that has resolved this issue.
Posted Apr 11, 2022 - 16:25 EDT

Investigating

We are currently investigating an issue that is impacting our portal's responsiveness. We will update this status post as more information becomes available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800) 580-4985 or (517) 322-0434 (international).
Posted Apr 11, 2022 - 16:13 EDT
This incident affected: Support Services (Tickets, Chats).