Issues with Salesforce
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted May 12, 2021 - 00:25 EDT
Investigating
We've been alerted to an issue that's impacting our ability to support our customers via chat. We're currently working with our 3rd party vendor to resolve this issue as quickly as possible. We apologize for any inconvenience that this may cause.
Posted May 11, 2021 - 18:06 EDT
This incident affected: Support Services (Tickets, Chats).