Nexcess Customer Portal Degraded
Incident Report for Server Status | Nexcess
Resolved
The Nexcess customer portal/dashboard has remained stable and the issue has been resolved.
Posted Nov 03, 2022 - 22:08 EDT
Monitoring
Our engineers have stabilized the portal/dashboard environment and will continue monitoring for any further issues.
Posted Nov 03, 2022 - 19:48 EDT
Investigating
We have identified an issue impacting the stability of the Nexcess customer portal/dashboard. Our engineers are currently looking into this.

Thank you for your patience. As we have updates we will post them here.
If you have any questions feel free to reach out to our support at 1-866-639-2377 or support@nexcess.net.
Posted Nov 03, 2022 - 18:34 EDT
This incident affected: Customer Portal.