Provisioning Delays
Incident Report for Server Status | Nexcess
Resolved
Our team has resolved the provisioning delays. We apologize for any inconvenience this may have caused.
Posted Apr 19, 2021 - 13:34 EDT
Identified
Our team has identified an issue causing provisioning delays. We are working as quickly as possible to resolve the delays and will provide updates here as new information is made available.

If you need any assistance with this, please reach out to our support team via Support Ticket, Email, or Phone at 1.866.639.2377.
Posted Apr 19, 2021 - 12:42 EDT