Our Engineering and Networking teams are continuing to implement mitigation measures and are actively working to mitigate elevated traffic levels impacting the environment. Systems are currently stable, though slight latency may still be experienced while conditions continue to normalize.
We will continue to closely monitor the environment to ensure stability and confirm that services remain operating normally.
Posted Mar 12, 2026 - 23:09 EDT
Update
Our Engineering and Networking teams have implemented a fix for the issue affecting servers in the UK South 2 region. Services are currently stable, though there may be slight latency while the systems continue to stabilize.
We will continue to monitor the systems to ensure stability and confirm that services remain operating normally.
Posted Mar 12, 2026 - 20:01 EDT
Monitoring
Our Engineering and Networking teams have implemented a fix for the issue affecting servers in the UK South 2 region. Services are currently stable, though there may be slight latency while the systems continue to stabilize.
We will continue to monitor the systems to ensure stability and confirm that services remain operating normally.
Posted Mar 12, 2026 - 11:15 EDT
Update
Our engineering and Networking teams are continuing to investigate the issue affecting servers in the UK South 2 region. We are currently observing intermittent connectivity latency, which may cause sites and servers to respond slowly and impact connectivity. The containers and APIs configured on customer sites might fail to connect. The team is actively working to identify the root cause and restore normal service as quickly as possible.
We appreciate your patience and understanding while we work to stabilize connectivity. Thank you.
Posted Mar 12, 2026 - 10:23 EDT
Investigating
We are currently investigating a connectivity issue affecting servers in the UK South 2 region and internal DNS resolvers. This may result in DNS resolution failures and impact connectivity to containers and APIs configured on customer sites. Our engineering team is actively working to identify the root cause and restore normal service as quickly as possible.
Need help? You can chat with us or create a ticket through my.nexcess.net.
We appreciate your patience and understanding while we work to stabilize connectivity. Thank you.
Posted Mar 12, 2026 - 08:40 EDT
This incident affects: Platform Operations (DNS) and Nexcess Cloud (uk-south-2).