DNS Service Disruption
Incident Report for Server Status | Nexcess
Resolved
We haven't observed any issues since the fix was implemented. Thank you for your patience as our team worked to resolve the issue.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, client portal ticket and live chat.
Posted Oct 09, 2024 - 10:11 EDT
Monitoring
Our System Engineer has fixed the DNS issue, and they are reporting online now. We are actively monitoring the services.

If you have any questions or concerns, please get in touch with our support team by emailing support@nexcess.net, using the client portal ticket, or live chat.
Posted Oct 09, 2024 - 07:56 EDT
Investigating
We are currently investigating an issue where a portion of DNS Services are degraded. This impacts other platform features as well. We will post further updates as we have more information.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, client portal ticket or live chat.
Posted Oct 09, 2024 - 07:01 EDT
This incident affected: Nexcess Global DNS.