We have been monitoring the situation, and everything has remained stable. This incident has now been resolved.
Posted Sep 26, 2026 - 20:01 EDT
Monitoring
Our team has confirmed that the affected Cloudhost services in the US-Midwest-2 region are operating normally. We are continuing to monitor the environment to ensure services remain stable.
We appreciate your patience while our team worked to resolve the issue.
Posted Sep 26, 2026 - 18:05 EDT
Identified
Our team has identified a subset of Cloudhost outages in the US-Midwest-2 region and is actively investigating the issue. We will provide another update as soon as more information becomes available.
We appreciate your patience as our team works to resolve this issue. If you have further questions or concerns, please contact us at support@nexcess.net or via Live Chat.
Posted Sep 26, 2026 - 15:26 EDT
This incident affected: Nexcess Cloud (us-midwest-2).