Nexcess Client Portal Access Issue

Incident Report for Nexcess Server Status

Resolved

The Nexcess Client Portal login issue has been resolved. Services are now fully operational, and no further impact has been observed.
Posted Aug 30, 2026 - 04:31 EDT

Monitoring

A fix has been implemented that resolves the issues with the portal login. We are currently monitoring the results to ensure stability.
Posted Aug 30, 2026 - 02:05 EDT

Investigating

We are investigating issues affecting the Nexcess Client Portal login at https://portal.nexcess.net/. Our engineering team is working to identify the cause and restore full availability as quickly as possible.

We will provide updates as more information becomes available. We appreciate your patience and understanding during this time.
Posted Aug 30, 2026 - 01:30 EDT
This incident affected: Customer Portal.