Nexcess Cart Degraded
Incident Report for Server Status | Nexcess
Resolved
This issue is now resolved. Our teams have implemented a fix and the cart is functioning as expected.
Posted Sep 15, 2022 - 15:41 EDT
Investigating
Our teams are currently investigating an issue with the display of our cart.
We will update the status post as soon as we have more information.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, client portal ticket, live chat, or toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Sep 15, 2022 - 12:39 EDT