nexcess.net website down
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted May 19, 2024 - 22:35 EDT
Investigating
Nexcess.net appears to not be loading for a subset of visitors. We are currently investigating the issue.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or call us at 866-639-2377, 313-279-0722 (international).
Posted May 19, 2024 - 21:55 EDT
This incident affected: Platform Operations (Web Services).