We continued to monitor the environment closely and can confirm that the system remains stable and fully operational.
This incident has now been resolved.
We sincerely appreciate your patience and understanding throughout the process.
If you have any questions or need further assistance, please don’t hesitate to contact us via live chat or by opening a support case.
Posted Aug 04, 2025 - 12:31 EDT
Update
This issue has been resolved, but we continue monitoring the situation.
Posted Aug 02, 2025 - 11:19 EDT
Monitoring
We successfully stopped the attack. However, we have added extra mitigation to reduce the attack and are continuing to monitor.
We appreciate your patience as our networking teams work to mitigate the DDoS. If you have any further questions or concerns, please feel free to contact us at support@nexcess.net or call us at 866-639-2377, 1-313-279-0722 (international).
Posted Aug 02, 2025 - 10:35 EDT
Identified
Our teams have identified a distributed denial of service attack (DDoS) on cloudhost-1298340-us-midwest-1-nxcli-net. Our network engineers have implemented mitigation, but we are still observing minor interruptions with the node. We will provide another update as soon as more information becomes available.
We appreciate your patience as our networking teams work to mitigate the DDoS. If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or call us at 866-639-2377, 1-313-279-0722 (international)
Posted Aug 02, 2025 - 10:28 EDT
Investigating
We have encountered an issue with cloudhost-1298340.us-midwest-1.nxcli.net.
Our engineers have identified the issue and are working on resolving the issue at this time.
Posted Aug 02, 2025 - 10:18 EDT
This incident affected: Nexcess Cloud (us-midwest-1).